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1.     Safety precautions and measurement conditions
· Prior to mounting the profilometer onto the wheel, areas of contact of the side

supports with the wheel surface should be thoroughly cleaned from dirt.
· When mounting the module on the wheel, do not allow heavy shocks of its support

against the wheel.
· The output window of the profilometer and profilometer supports must be carefully

inspected and cleaned. 
· Do not use laser module in locations close to powerful light sources.

2.     Electromagnetic compatibility
The profilometer have been developed for use in industry and meet the

requirements of the following standards:
· EN 55022:2006 Information Technology Equipment. Radio disturbance

characteristics. Limits and methods of measurement. 
· EN 61000-6-2:2005 Electromagnetic compatibility (EMC). Generic standards.

Immunity for industrial environments.
· EN 61326-1:2006 Electrical Equipment for Measurement, Control, and

Laboratory Use. EMC Requirements. General requirements.

3.     Laser safety
The profilometer make use of an c.w. 660 (or 405) nm wavelength semiconductor

laser. Maximum output power is 1 mW. The device belongs to the 2 laser safety class
according  IEC 60825-1:2007. The following warning label is placed on the profilometer
body:

The following safety measures should be taken while operating the profilometer:
· Do not target laser beam to humans; 
· Do not disassemble the sensor;
· Avoid staring into the laser beam.

4.     General information
A laser profilometer IKP5 Series is designed for the measuring of
· wheel flange height 
· wheel flange thickness  
· wheel flange slope
· rim thickness 
· full profile scanning and analyze of wheel rolling surface
· maintaining of electronic wear data base
· control of tolerances and sorting in the course of checkup, examination, repair and

formation of railway wheel sets. 
Measurements are made directly on rolling stock without wheel set roll-out. 
Profilometers are implemented in three configurations: with the standard handle,

with the shorten handle (Short version) and very short handle (Super short version). The
version with the shorten handle is intended to measure the wheels with the limited space for
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installing the profilometer. The version with very short handle is specially designed to
measure wheels of Ansaldo Breda low floor trams with very limited space for
profilometer installing. This super short profilometer version has separate battery block,
connected by cable with laser module.

5.     Basic technical data

Name of parameter Value

Measurement range  

flange height, mm
flange thickness, mm
flange  slope, mm
rim thickness, mm
diameter (calculation method), mm

20…45
20…50
1…15

36…100 (30...90)
400…1400

Measurement error

flange height, mm
flange thickness, mm
flange  slope, mm
rim thickness, mm
diameter, mm

± 0,1
± 0,1
± 0,2
± 0,5
± 0,1

Discreteness of indication 

all parameters, mm 0,01

Profile measurement range, mm 145 

Discreteness of the profile formation, not worse than, mm 0,1

Digital readout device (PDA) dimensions, mm see Fig. 3

Dimensions of laser scanning module, mm see Fig. 5

Power supply (laser scanning module) 4,8V,
4 AAA rechargeable batteries, 1,2V 

Power supply (PDA) 3,7V
Li-polymer battery

3300mAh

The  number  of measurements that can  be taken before 
battery  recharge is not less than

1000

PDA memory capacity 100 000 measurements

Interface between laser scanning module and PDA Bluetooth 

Working temperature range, °С -15…+35

Enclosure rating IP42

6.     Example of designation when ordering
IKP-Short-М -S-T

Sym bol De scription

without
symbol or
Short or
Sshort 

Standard version or version of the profilometer with the shorten handle or super short
handle.

M Options of the set of magnets for mounting on the internal/external rim face:
S – standard. Standard magnets (specified by default).
F – forced. Reinforced magnets.

S Options of the support plates embodiment:
D – direct. Standard plates, profilometer is mounted on the internal rim face (specified by
default).
I – invert. Custom plates, profilometer is mounted on the external rim face.

T Presence of the rim measurement rod.
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Example: 
IKP-Т  – standard magnets; standard support plates; presence of the rim

measurement rod. 
IKP-F-I – reinforced magnets; custom support plates. 
IKP-Short-T – the shorten handle; presence of the rim measurement rod.

7.     Complete set to be supplied

De signa tion Na m e Qua ntity W e ight,
kg

RF303М Digital readout device (PDA) 1 0,3

RF505 Laser scanning module 1 0,8

RF505.40 Charging device 9V 3.0A for PDA 1 0,2

RF505.41 Charging device  9V 3.0A for laser module 1 0,2

RF505.42 Data cable  1

RF505.43 Bluetooth adapter 1

RF505.30 Packing case 1 1,2

IKP5_DB Database management system  (CD) 1

RF505UM User's manual 1

Ca libra tion tools (option):

RF505.11 Calibration block 4

RF505Calibr Calibration software 

The profilometer comes in the special case
that protects the device against any
possible damage.
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8.     Device structure

8.1.     Basic components of the device and their functions

Fig. 1 shows basic components of the device:

Figure  1

(1) Digital readout device (personal digital assistant, PDA) 
(2) Laser scanning module 
(3) Calibration block
(4) Charging device
(5) Data cable  

8.1.1.     Digital readout device

Digital readout device (PDA) is designed for control of the laser scanning module,
data reception from the scanning module, indication of measurement results, parameter
input, and data storage.

Figure  2

Fig. 2 indicates:
(1) Turn-on button
(2) Charging indication, red/blue LED
(3) Connector to PC USB-port or charging device 
(4) Flash memory card connector
(5) Stylus
(6) Bluetooth antenna 
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Overall dimensions of PDA are shown in figure 3:

Figure  3

8.1.2.     Laser scanning module

The module is intended for laser scanning of the wheel surface.

Figure  4

Fig. 4 indicates:
(1) Turn ON button
(2) Indicator of turn ON (red LED)
(3) Indicator of Bluetooth connection (blue LED)
(4) Charging device connector 
(5) Support for mounting of the device on the wheel flange
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(6) Magnetic support for mounting on the wheel side surface
(7) Charging indication, red/green LED
(8) Output window
(9) Rim measurement rod
Overall dimensions of the standard scanning module are shown in figure 5.

Figure  5

Overall dimensions of the scanning module with the shortened handle are shown in
figure 6.

Figure  6

Overall dimensions of super short scanning module and battery block are shown in
figure 6.1.
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Figure  6.1

8.1.3.     Calibration block

Calibration block is intended for calibration and tests of the profilometer. Calibration
block is a metal imitator of the part of wheel with a definite profile.

Overall dimensions of calibration block are shown in figure 1A of paragraph 30.3.
Also possible is supply of a unit with a profile made to the customer’s drawings.

9.     Operation principle
Operator mounts the laser scanning module onto the wheel to be measured. Having

received a command from PDA or PC, the laser module performs non-contact scanning of
the wheel surface. Measurement results (geometric parameters and profile of the surface)
are displayed on PDA, can be saved in the PDA memory, and transferred to the PC
database. Simultaneously, additional parameters can be saved: operator number, side
identifier (left or right wheel), axis number, locomotive (carriage) number, wheel pair
number, etc.

Video demonstration: https://riftek.com/eng/products/~show/instruments/railway-
devices/railway-wheel-profile-gauge-ikp

https://riftek.com/eng/products/~show/instruments/railway-devices/railway-wheel-profile-gauge-ikp
https://riftek.com/eng/products/~show/instruments/railway-devices/railway-wheel-profile-gauge-ikp
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10.     Geometric parameters of the wheel under
control

Geometric parameters of the wheel are calculated automatically after laser
scanning of the wheel is completed. To calculate geometric parameters, use is made of
reference points on the wheel profile. Location of the reference points is defined by L- and
P-parameters. Values of L- and P-parameters preset in PDA are given in paragraph 14.4.
and can be changed by the user.

10.1.     Flange height, sH

Calculation of the flange height is determined by parameter L2.
The flange height is calculated as a distance measured vertically between the

flange top and the point of wheel rolling surface at any preselected distance (L2) away from
the inner face of the wheel tire.

10.2.     Flange thickness, sD

Calculation of the flange thickness is determined by parameter L3 that specifies
Point 1 on the flange surface. There are two ways to specify the parameter:

Method 1

Height L3 is measured vertically
upward from a point of the wheel
rolling surface, the position of which
is defined by parameter L2.

Method 2

Height L3 is measured vertically
downward from the flange top.

The flange thickness is calculated as a distance measured horizontally at any
preselected height (L3) between two points (Point 1 and Point 2) lying on the opposite
sides of the flange top.

There are two ways to calculate the flange thickness:

Method 1

Point 1 is defined by parameter L3.
Point 2 is the intersection point of a
horizontal line and a line lying on the
internal face of the wheel.
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Method 2

Point 1 is defined by parameter L3.
Point 2 is the intersection point of a
horizontal line and the flange surface. 

Note: Both calculation methods can be performed simultaneously.

10.3.     Flange slope, qR

Calculation of the flange slope is determined by parameters L1 and L3 (or L4).

Height L1 is measured vertically downward from the
flange top and determines Point 3 on the flange
surface.
Height L4 is measured vertically upward from a point
of the wheel rolling surface, the position of which is
defined by parameter L2 (wheel rolling circle), and
determines Point 4 on the flange surface.
Height L3 is described in paragraph 10.2.

There are three ways to calculate the flange slope:

Method 1
Ca lcula tion in m illim e te rs

The flange slope is calculated as a
distance measured horizontally
between Point 3 and Point 1 (or 4). the
The PDA screen displays information
in millimeters.

Method 2
Ca lcula tion in de gre e s

The slope is calculated as the
inclination angle of a straight line
passing through Point 1 or 4. 
The PDA screen displays information
in degrees.

Method 3
Pa ss/Fa il

The calculation is performed according
to Method 1.
The PDA screen displays information
only about whether the measured slope
meets the tolerance conditions or not.

10.4.     Wear parameters

The following wear parameters are calculated automatically:

Vertical wear  Wt is calculated as the difference between the measured flange height and the
flange height of the selected reference.

Horizontal wear  Wf is calculated as the difference between the measured flange thickness and the
flange thickness of the selected reference at the height L3. 

Corner wear  Wr is calculated as the distance along the normal to the tangent at a point on the
height L5 from the wheel rolling circle of the measured profile, and the selected
reference. 
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* Red color indicates the worn profile 

Hollow Hl is calculated as the difference between the maximum and minimum values
within the specified limits.
The search limits:
- parameters of the minimum value [P7_1..P7_2]
- parameters of the maximum value [P8_1..P8_2]

Difference of
diameters

dD is calculated as the difference between diameter at point D1 and diameter at
point D2. 

Even wear  W1 is the maximum vertical wheel wear selected from several measurements.

Uneven wear W2 is the difference between the maximum wheel wear and the minimum wheel
wear (selected from several measurements).

10.5.     Angle parameters

The following profile parameters are calculated automatically:

Inclination A is calculated as the profile inclination angle (in degrees) at a point with coordinate
L8.

Angle 1 S1 is calculated as the inclination angle of the straight line (in percents) passing
through points on the wheel surface located at preset distance L6 from the wheel
face and the distance L6+10mm from the wheel face.

Angle 2 S2 is calculated as the inclination angle of the straight line (in percents) passing
through points on the wheel surface located at preset distance L7 from the wheel
face and the distance L7+10mm from the wheel face.
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10.6.     Rim parameters

The following rim parameters are calculated automatically: 

Rim width L is calculated as a distance measured vertically between the internal and
the external basic wheel surface.

Rim thickness sT is calculated as a distance measured vertically between the internal rim
diameter and a point on the wheel rolling circle located on any preset
distance L2 from the wheel face.

L11 is an external wheel diameter.

10.7.     Wheel diameter

Diameter D is calculated by the formula:
D =  2*T +L10, 
T – rim thickness
L10 – diameter of the wheel center

10.8.     Parameters of tram wheels

The following parameters of the tram wheels profile are calculated automatically:

Flange thickness sD15 is calculated as a distance measured horizontally at the set height (L15)
between two points: 1st point is at the internal flange surface, 2nd point is
at the line lying on the internal face of the wheel surface.

Flange thickness Df is calculated as a distance measured horizontally at the set height (L3)
from the surface of the wheel rolling circle between two points lying on
opposite sides from the flange top.

Reverse slope f is calculated as a distance measured horizontally from the point on the
internal flange side at the set height (L3) to the point on the line lying on
the internal face of the wheel.
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10.9.     Wheel defects

The following parameters of defects of the wheel surface are calculated:

Slide sP is calculated as a difference of the wear measurements in two places of the
wheel: on the slide and close to it (in the place without defects) at the point
on the wheel rolling circle at any preset distance (L2) from the wheel face.

Cavity size hR is calculated as a difference of the wear measurements in two places of the
wheel: on the cavity and close to it (in the place without defects) at any
profile point.

Cavity area sR is calculated in the place of the maximum deviation.

11.     Coordinate system
When comparing the profiles, two variants of location of the coordinate system of

the wheel is possible to use.

Coordinate system origin

Top
When comparing and displaying profiles, the
coordinate system origin is located at the
intersection point of lines passing through the
profile top and the internal wheel surface.

W he e l rolling circle
When comparing and displaying profiles, the
coordinate system origin is located at the
intersection point of lines passing through the
wheel rolling circle.

12.     First activation and measurement procedure
Charge accumulators of the laser module and indication device by connecting them

to charging devices (see par. 28). 

12.1.     Activation

· Turn the PDA on by pressing the button (1), Fig. 2. The PDA screen will show the
main program window containing: main menu; indicators of PDA and laser
module charging degree; indicator of Bluetooth connection. 
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Button Assignm e nt

Device Setting the PDA basic parameters (p.13) 

Parameters Setting the measurement parameters (p.14)

Settings Setting parameters of database, tolerances, and others (p.15)

Profiles View the wheelset profile (p.20.2.)

Measurement Run the measurement process (p.12.2.)

· Switch the laser module on by pressing and holding button 1 (Fig. 4) for several
seconds. When connecting the laser module, a red LED blinks (2). 

· After the laser module  is  switched on, some time will pass until automatic
wireless communication is set between the profilometer and the PDA, which is
accompanied by  blinking  of  a  blue  LED  (3) on  the laser module. The LED
goes out when the link is established. 

· The main program window will be updated.  

The Measurement button, indicator of Bluetooth connection, serial number of the
laser scanning module, and indicators of the charging degree will be active.

12.2.     Measurement

There are two types of measurements:
1. Rapid measurements without saving the results.
2. Measurements by using the selected scheme with saving results to database.
The measurement procedure by using type 2 is described in par. 18. How to select

the measurement type see in par. 13.1. 
Measurement by using the scheme (type 2) is used for full-featured work with the

profilometer with maintaining the database of measurements.

Attention! 
Before installing the scanning module onto the wheel, you need to remove the dirt from the areas,
where the laser scanning module will be in contact with the wheel surface. 
When installing the laser scanning module onto the wheel, avoid of strong impacts of its supports,
because it can lead to incorrect operation of the profilometer.
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You need to inspect periodically the output window and basic supports of the laser scanning
module and to clean them of dirt. 
Do not clean the glass by using abrasive and aggressive cleaning agents. 

To perform the measurement, it is necessary to:
· Fix the laser module on the calibration unit or wheel by mounting the module

support (5) onto the wheel flange and pressing magnetic support (6) to the internal
face of the wheel.

· For the rim measurement, extract the rim measurement rod and hitch it up to the
rim.

Figure  6

· Make sure that the module is mounted correctly without any misalignment and
gaps.

· Press the Measurement button on the PDA display.
· With the Measurement button pressed, the laser module will scan the wheel

surface. During scanning time of about 1-2 seconds a red LED (2) is lit. 
· When scanning is competed, the PDA will show values of measured parameters

selected for presentation (see par.14.2.). 

When the parameter goes beyond set limits its value is highlighted with red color: 
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19 The R eference option enables/disables the display of the reference profile
parameters on the screen (highlighted in green ).

· To view the wheel profile, press the Profile button, and the PDA display will show
the scanned wheel profile, the measured parameters, and parameters of
calibration unit (or a wheel, chosen as a reference):

· If you scan the calibration block or the reference wheel and scanning results differ
from the reference values by nor more than 0.1 mm, the device is ready to work,
otherwise it must be calibrated in accordance with par. 27.1 or 30.

The Save button is not active in the Rapid measurements mode.

13.     PDA basic parameters setting
Prior to starting work with the profilometer, PDA program setting must be

performed.
The window of basic parameters setting is called by pressing the Device button in

the main program window (par. 12.1.):



20

Laser Wheel Profilometer. IKP-5 Series, Model 2016 Year

IKP-5 Series, Model 2016 Year [Revision 3.0.0] 04.01.2016 

Button Assignm e nt

Measure type Rapid measurements/measurements with saving results to database

Units of measurement Millimeters/inches

Date/time Date/time setting

Device type Device selection (IKP, IDK, IМR)

Language Language selection

Synchronization Synchronization with PC 

13.1.     Measurement type

Two measurement types are available:
1. Rapid measurements without saving the results.
2. Measurements by using the selected scheme with saving results to database.
To set the measure type, press the Measure type button. Then select the measure

type: Rapid measurement or Measurement by scheme. Press the Save button.

13.2.     Units of measurement

All parameters and measurement results can be in the Metric system (millimeters),
or in the English system (inches). To set the units of measurement, press the Units button.
Next, select Millimeters (mm) or Inches (in), and press Save.
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13.3.     Date/time setting

To set date and time, press the Date/Time button. Next, by using the buttons  ,
set the date and time values, and press the Save button.

13.4.     Device selection

PDA Bluetooth-connection is automatically configured to work with the laser
scanning module, which comes bundled with the PDA. Moreover, the PDA provides
operation with other IKP scanning modules and measurement instruments for railway
transport manufactured by RIFTEK (Wheel Diameter Measuring Gauge, IDK; Back-to-Back
Distance Measuring Gauge, IMR).

To connect other device, press the Device type button. The device selection
window contains 3 types of devices available for connecting to PDA: IKP, IDK, IMR. 

Each type of devices has a list of available devices (devices, with which connection
has been established earlier, and which have been saved in the IKP memory).

If the device that you need is included in the list, you can select it and press the 
Select button. The PDA will attempt to connect to the selected device.

If the device number is absent in the list, you can add it. In order to do it, you need to
press the Add button and to go to the window for searching Bluetooth devices.
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To search for devices, press the Start button and wait until the search is completed:

Detected devices (with serial numbers) will appear on the screen: 

Next, select the device and press the Save button to save the address of a new
device. 

You can delete the device that you do not use anymore by pressing the Delete
button.
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13.5.     Language setting

It is possible for the user to change the program language, form his own language
support files as well as change/edit the terminology used.

To select the language, press the Language button. Next, select the required
language support file and press the Select button.

If no such file is available, it is necessary to use the new files preparation procedure,
which is described in par. 22.2.4.1., and then load a new language file from PC to PDA as it
is shown in par. 23.1.3.

13.6.     Synchronization with PC

To transfer data between PDA and PC, it is necessary to synchronize them. There
are two ways of synchronization via USB cable.

When you select MS ActiveSync, synchronization with PC is performed via the
ActiveSync software (Windows XP), or via Windows Mobile Device Center (Windows
7).  

When you select Mass Storage, the device is detected in Windows as an external
storage device.

To select the type of synchronization, press the Synchronization button in the
Device window. Next, select the required type and press Save.

To apply the changes, PDA will prompt you to restart. If you do not need to sync the
PDA with PC currently, you can restart the PDA later.
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14.     Measurement parameters setting
The Parameters window, which is called from the main program window, is

intended for calculation settings of controlled parameters of the wheel.

Button Assignm e nt

Settings Calculation methods setting 

Show param. Selection of displayed parameters

L Parameters L Parameters setting

14.1.     Calculation methods setting

To select the method of the geometrical parameters calculation, press the Settings
button. The window of measurement settings will appear on the screen according to par. 10:

After selecting the required parameters, press the Save button.
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14.2.     Selection of displayed parameters

To enable the mode, press the Show param. button.

 To select/deselect the parameter to display, double-click in the column Show/Hide
opposite to the required parameter. After selecting, you need to press Save.

14.3.     L Parameters setting

To set L-parameters, press the L Parameters button.
In the table will be displayed only those parameters, which are necessary to

calculate the selected geometrical parameters of the wheel.

To edit the parameters, double-click in the Value column opposite to the required

parameter, and enter a new value in the Data Input window. Press the Enter button - .

When you set all parameters, press the Save button to save them.
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14.4.     Preset parameters values

Values of L-parameters preset in the PDA are given in the Table:

L-
параметр

Default value Assignment

L1 2 mm Used for calculation of the flange slope (qR) 

L2 70 mm Defines position of the wheel rolling circle, and used for calculation:
- flange height (sH)
- flange thickness (sD)
- flange slope (qR)
- inclination angle (A)
- wheel diameter (D)
- rim thickness (T)
- wear (Wt, Wf, Wr)

L3 13 mm Used for calculation:
- flange thickness (sD)
- flange slope (qR)
- wear (Wf)

L4 13 mm An additional point for calculation of the flange slope (qR)

L5 10 mm Used for calculation of an angular wear (Wr)

L6 70 mm Used for calculation of slope of the rolling surface section (S1)

L7 105 mm Used for calculation of slope of the rolling surface section (S2)

L8 10 mm Used for measurement of the profile inclination angle at the required
point (A)

L9 140 mm Used for inverting the measurement direction (L9 – profile width)

L10 599,35 mm Used for calculation of the profile diameter (D)

L11 767 mm Used for calculation of the reference profile rim thickness (T)

L15 13 mm Used for calculation of the flange thickness of tram wheels (sD15)

P7_1 
P7_2
P8_1
P8_2

50 mm
105 mm
110 mm
130 mm

Used for calculation of the hollow (Hl)

D1 
D2

70 mm
107,5 mm

Used for calculation of the hollow (Hl)
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15.     Setting the database parameters, tolerances and
measurements schemes

The Settings window is intended to set the database parameters, tolerances,
measurements schemes, etc.

Button Assignm e nt

Database Selection of the current database 

Reference Reference profile selection 

Scheme Measurement scheme setting 

Tolerance Tolerances setting 

Wheel type Wheel type selection 

15.1.     Selection of the current database

You can save the measurement results to the PDA database, when it is necessary.
The program allows to create and to store several database files related to the date of
measurement.

To select the database file, press the Database button.

To create a new database, press the Add button. The window for entering a name
of a new database will appear.

By default, it will be prompted to form the database file with the name 
wp_yy_mm_dd.ikp, where yy_mm_dd is the current date:

yy   – the last two digits of the year;
mm – month;
dd  – day.
You can agree with this name, or enter another:
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Then, press the Enter button - .

To select a database from a list of previously created, activate the respective line
and press Select. The selected file will be marked with the symbol "·". 

To delete the database file, activate the respective line and press Delete. If you
delete the current database, the error message will appear.

15.2.     Reference profile selection and installation

The program allows to compare the scanned profile of the wheel with the reference
profile. To select the reference profile, press the Reference button.

To select the reference file, activate the respective line and press Select. The
selected file will be marked with the symbol "·". 

To delete the reference file, activate the respective line and press Delete. If you
delete the current reference, the error message will appear.
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15.2.1.     Writing reference profile to database

Reference profiles are stored in the PDA database as profile description files with
extension .ref. The PDA is supplied with several pre-installed profiles. 

If there is no required reference profile in the database, the user can request the
lacking profile from RIFTEK (free service), and then to transfer the received profile to the
PDA as it is shown in par. 23.1.4.

15.3.     Selection and formation of the measurement scheme

Measurement scheme is meant as a sequence of making
measurements/processing of wheels in the rolling stock with specified parameters of each
wheelset (wheelset numbers, car numbers, series, etc.). The program automatically offers
operator to perform measurement on a concrete wheel in accordance with selected
scheme of wheel processing. The program contains several preset schemes. Besides, the
user can form his own measurement scheme.

15.3.1.     Selection or removal of the measurement scheme

To select the measurement scheme file, press the Scheme button.

To view the scheme, you need to activate the line containing the scheme file name

and to press the View button .

Arrows in the figure show direction of processing of wheel pairs as well as the
names assigned to wheels (1L-first axis, left side; 2L-second axis, left side; 1R-first axis,
right side, etc.).

To select the scheme file, activate the respective line and press Select. The
selected file will be marked with the symbol "·". 

To delete the scheme file, activate the respective line and press Delete. If you
delete the current scheme, the error message will appear.
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15.3.2.     Formation of a new measurement scheme

To form a new measurement scheme, press Add. The window for entering the
measurement scheme name will appear.

By using on-screen keyboard type the scheme name. Then press the Enter button -

.

Next:
· select the number of cars;
· select the number of axles; 
· select the wheel processing scheme out of the options suggested;
· press Save.

You can look at the formed scheme by pressing the View button - .
This method of formation the measurement scheme allows to create only simple

schemes without specifying the numbers of wheelsets, coaches, series, etc. To form a
complete scheme, see par. 29.

15.3.3.     Loading of a new measurement scheme

If you can not create a new scheme as described in the previous paragraph, you
can use the special program for PC (see par. 29), and then upload that scheme to the PDA
as described in par. 23.1.5.

15.4.     Tolerances setting

The program automatically controls measured geometric parameters for going out
beyond the tolerances set. It is possible for the user to create groups of tolerances. Control
of parameters will be performed for a selected group. 

To select the current group of tolerances, press the Tolerance button.
The table will show tolerances only for the selected geometric parameters of the

wheel.
A red color indicates the maximum/minimum critical values of parameters. An

orange color indicates the maximum/minimum values, which are close to critical values.
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To select the group of tolerances, activate the respective line and press Select. The
selected file will be marked with the symbol "·".

To delete the tolerance, activate the respective line and press Delete. If you delete
the current tolerance, the error message will appear.

To edit the tolerance, activate the respective line and press Edit.
To add a new tolerance, activate the line with the type name and press Add. View

on the screen:

To change the type name, it is necessary to set cursor in the Name of Tolerance

field, and to enter a new value in the appeared window. Then press the Enter button - .
To edit the value, it is necessary to double-click on the Min/Max/War.Min/War.Max

column opposite to the specific parameter, and to enter a new value in the emerged
window. Then press the Enter button. If any parameter has a zero value, the tolerance will
not be used.

To save changes, press Save.

15.5.     Wheel type selection and installation

If several wheels types are used, it is possible to set definite measurement scheme,
reference profile and L-parameters for every wheel type 

For example, we have three types of wheels: WheelType1, WheelType2,
WheelType3. Every time for a new wheel type we can measure L-parameters, scheme,
reference and tolerances, or we can define these values for every wheel type, and select
only the required type.  

Example
WheelType 1: Reference 1, Scheme 1, Tolerance 1, L-Parameters 1;
WheelType 2: Reference 2, Scheme 2, Tolerance 2, L-Parameters 2;
WheelType 3: Reference 3, Scheme 3, Tolerance 3, L-Parameters 3;

To select the wheel type, press the Wheel type button.

To select the wheel type, activate the respective line and press Apply. The selected
file will be marked with the symbol "·". 
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To delete the wheel type, activate the respective line and press Delete. If you delete
the current type, the error message will appear.

To edit the wheel type, activate the respective line and press Edit. 
To add a new wheel type, activate the line with the type name and press Add. View

on the screen:

To change the type name, it is necessary to set cursor in the Name field, and to

enter a new value in the appeared window. Then press the Enter button - .
Next:
· select the reference profile (Reference);
· select the scheme (Scheme);
· select the tolerance (Tolerance);
· set Settings (Settings button, see par. 14.1.);
· set the displayed parameters (Show param. button, see par. 14.2.);
· set L-parameters (L Parameters button, see par. 14.3.);
· press Save.

16.     Updating of PDA software
You can view the software version in the main program window: 

The latest software version can be downloaded from the site:
www.riftek.com/media/documents/ikp/Ikp5_PDA_Software.zip
Procedure of PDA software updating is described in par. 23.1.6. of this manual.

http://www.riftek.com/media/documents/ikp/Ikp5_PDA_Software.zip
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17.     Shutdown
To shutdown the PDA, press the Shutdown button - . 

18.     Measurements with database maintenance
There are two types of measurements:
1. Rapid measurements without saving the results.
2. Measurements by using the selected scheme with saving results to the database.
Procedure of rapid measurements is described in par. 12. How to select the

measurement type, see par. 12.2. 
The second type is used for a fully functional work with the profilometer with

maintenance of the measurements database. 
When Bluetooth-connection is established, you can pass to measurement by

pressing the Measurement button in the main program window. The window for entering
wheelset parameters will appear on the screen:

Parameters fields will be filled in accordance with the selected measurement
scheme. If needed, you can fill/edit the required fields, and press the Save button to save
changes. The selected scheme will be displayed on the screen:
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Designations and buttons:

order number of the car to be measured (number of cars in the train)

editing of the inputted wheelset parameters

pass to a previous/subsequent wheel 

pass to a previous/subsequent car

a measured wheel 

a wheel to be measured next time

a non-measured wheel 

a measured wheel to be measured again 

measurement

18.1.     Measurement

· Measure the wheel offered by program (highlighted in green). To do this, click the 
Measure button. Laser module will scan the wheel surface. 

· Upon completion of the scanning process, the measured values of geometrical
parameters selected for displaying will appear on the PDA screen.  

Measured values, which are beyond the tolerances, will be highlighted in red:

The program allows to display only parameters of the measured profile. To hide the
reference values, you need to uncheck the Reference checkbox.
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· To view the wheel profile, press the View button - . The scanned wheel profile

and the selected reference profile will be displayed on the PDA screen.

For more information, see par. 20.2.
· To perform the measurement again, press the Measure button. 
· When a satisfactory result is obtained, press the Save button to save it.
· The program will offer to pass to measurement of the next wheel in accordance

with selected scheme of measurement.

· To view the results of previous measurements, you can use the arrows. If you
select the measured wheel, the saved wheel parameters will be displayed on the
PDA screen.
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· When you measure the wheel that was previously measured, the program prompts
you to replace the existed database file with the new one.

18.2.     Measurement of even/uneven wear

Measurement of an even/uneven wear is slightly different from a standard
measurement. To obtain the result of the wear, it is necessary to perform several
measurements at different points of the wheel. When passing to the measurement window,
an additional button Accept will appear on the screen.

After each performed measurement, you need to press Accept to save current
values of the wear. At subsequent measurements the program will automatically find the
maximum and minimum wear of the wheel and calculate an even/uneven wear.

When a satisfactory result is obtained, press the Save button to save it.

18.3.     Measurement of defects

IKP allows to measure defects of wheelsets.
· Slide size (sP)
· Cavity size (hR)
· Cavity area (sR)
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Measurement of defects differs from the standard measurement.
The procedure of measuring the slide (cavity) is described below: 
· Perform the measurement at the profile point that do not have any defects (slides,

cavities), which can be detected visually. 

· If you obtained a satisfactory result, press the Apply button. The checkboxes
Slide and Cavity will appear on the screen. 

· Select the defect that you need to measure (tick the required checkbox).
· Place the profilometer properly (a laser beam must pass through the measured

defect).
· Press the Measure button to start the measurement.
Upon completion of the measurement, the program calculates the value of selected

parameter.
When a satisfactory result is obtained, press Save to save data to database.

19.     Measuring by IKP, IDK, IMR, and saving to
database

How to use the PDA with other devices is described in the corresponding User's
Manuals.

It is often needed that the measurement results obtained from different devices
were stored in one database. In this case, all entered parameters of the specific wheelset
must be the same in all devices.

These parameters are:
· Date
· N wheelset
· Series 
· Number
· Axle 
· Side (besides IMR)
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20.     Browsing the database
To browse the saved data, press the Profiles button in the main window. The PDA

screen will display information about the current database, quantity of saved profiles, table
with saved profiles, and measured values of selected parameters.

Buttons:

Pass to browsing the profile of selected wheel 

Delete the selected wheel

Add a filter when browsing the database

Delete a filter 

Save the reference file

20.1.     Data filtering

To add a filter, you need to press the Filter button, and to set filter parameters in the
appeared window.

An example of filtering by the Axle parameter:
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The filtered field will be highlighted in yellow: 

To delete a current filter, you need to press .

20.2.     Visualization of the wheel profile

To browse the wheel profile, you need to press the Profile button - . The
scanned wheel profile and the profile of selected reference will be displayed on the PDA
screen. 

Buttons for operating with profiles:

Zoom in

Zoom out

Standard image scale

Browse the profile wear 

An example of a zoomed image:
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An example of visualizing the profile wear.
Information about the wear area is displayed on the screen. A positive wear area is

highlighted in green, a negative one - in blue.

21.     Installation of software on PC and startup

21.1.     Installation of database support software

The ikp5_DB software is intended for maintaining wheel sets wear database on a
personal computer (the updated version of the program can be downloaded from 
www.riftek.com/media/documents/ikp/Ikp5_PC_Software.zip). 

To install the software, insert a compact disk to the PC CD drive, select and start
the Install_Ikp5.exe file in the Software folder. Follow guidelines of the installation wizard.
By default, the software will be installed in the following directory C:\Program Files (x86)
\Riftek, LLC\Ikp5_db\.

21.2.     Synchronization of PDA and PC

There are two ways of synchronization via USB cable to transfer data between PDA
and PC:  

· MS ActiveSync
· Mass Storage 
When you select MS ActiveSync, synchronization with PC is performed via the

ActiveSync software (Windows XP), or via Windows Mobile Device Center (Windows
7), which need to be installed on PC.

It is necessary to select MS ActiveSync as the synchronization type (see par.
13.6.).

When you select Mass Storage, the device will be detected in Windows as an
external storage device.

It is necessary to select Mass Storage as the synchronization type (see par. 13.6.).

http://www.riftek.com/media/documents/ikp/Ikp5_PC_Software.zip
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To check if the MS ActiveSync synchronization is correct, switch on the PDA and
connect it to the USB port of the PC by the supplied cable. If the connection is successful, a
message about it will appear on the screen:

21.3.     Program startup

To start the program, click Start > All programs > Riftek, LLC > IKP5_DB >
Ikp5_DB.exe. View of the main program window is shown below.
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22.     User settings of the program

22.1.     Parameters setting

To go to the window of parameters setting, click Settings > Parameters in the

main window, or click .

The window of parameters contains 4 tabs:
· Wheelset's parameters
· Calculated parameters
· L parameters
· Measurement method

22.1.1.     "Wheelset's parameters" tab

This tab is intended to select parameters, which will be displayed on the screen
when viewing the database.

If the parameter is ticked, its value will be shown in the table of results and in the
table of profiles. 
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22.1.2.     "Calculated parameters" tab

This tab is intended to select the wheelset geometrical parameters, which will be
calculated and displayed on the screen when viewing the database.

Description and functions of parameters are the same as in the PDA software (see
par. 10.).

22.1.3.     "L parameters" tab

This tab is intended to set the values of reference points for calculated geometrical
parameters of the wheelset.

Description and functions of the reference points are the same as in the PDA
software (see par. 10.).

22.1.4.     "Measurement method" tab

This tab is intended to select the calculation method.

Description and functions of the measurement methods are the same as in the PDA
software (see par.10.).
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22.1.4.1.     Selection of measurement units

All parameters and measurement results can be in the Metric system (millimeters),
or in the English system (inches). 

To set the units of measurement, you need to select mm or inches in the Units of
measurement field. After saving the changes, all information will be displayed in the
selected units of measurement.

22.2.     Database settings

22.2.1.     Setting the path to database

The program allows the user to change the drive and the directory of the profiles
database storage. To do it, select File > Path to DB... in the main menu window.

Next:
· click Ok 
· specify a new path to the database 
· confirm the creation of a new database 

After that, all database files will be copied to the specified path. 
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22.2.2.     Creation of empty database

To create an empty database, select File > New DB in the main menu.

All data, excepting the reference files, will be deleted from the database. At the
same time, catalog DB(dd.mm.yy) will be created in the installation directory whereto all
deleted data (dd.mm.yy – current date) will be copied. Subsequently, these data can be
restored (see par. 22.2.3).

22.2.3.     Import of database

To import data to the database from the other database (previously saved) you
need to:

· Select File > Import Data in the menu.
· Select the folder with DB files in the left-hand window. All files will appear in the

right-hand window:

· Click OK to import data.

22.2.4.     Selection of software language

To choose the software language, select Settings > Language in the main window
menu and set the required language support file.  
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22.2.4.1.     Preparation and installation of the language support file

The user can change the language, form his own language support files as well as
change/edit the terminology used. Language support files are located in the directory used
in the process of installation. By default the following directory is used: C:\Program Files
(x86)\Riftek, LLC\Ikp5_db\Language\. 

The directory contains two files, RUS.lng and ENG.lng, to support Russian and
English languages respectively. 

To create the support file for any other language, it is necessary to: 
· copy one of the existing files. For example, ENG.lng under the other name, for

example, DEU.lng; 
· edit the renamed file by using any text processor, namely, change all terms and

phrases to analogous ones from the required language;
· save the edited *.lng file in the Language folder.
To change and edit terminology, it is necessary to:
· edit the corresponding language file by using any text processor;
· save the edited *.lng file in the Language folder.

22.3.     Registration data

22.3.1.     Selection of the organization

To add/select the user organization, select in the main window menu Registration
> Organization. Subsequently, this information will be used for obtaining data from the
selected depot and for generating reports.

Buttons functions:

Add a new organization

Delete the selected organization

Edit the selected organization

Exit the organization registration mode

To select a current organization:
· Click Edit
· Tick the depot
· Click Save
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22.3.2.     Registration of operators

Steps to follow: menu Registration > Operator. Operators data are used for
identifying operators by Number.

Functions of buttons are similar to those in par. 22.3.1.

22.3.3.     Registration of series

Steps to follow: menu Registration > Series. Registered series of cars or
locomotives are displayed in the emerged window.  

When registering a new series, a new entry for this series will be added in the table
of tolerances automatically (see par. 22.3.5).

Functions of buttons are similar to those in par. 22.3.1.
When adding a new series, it is necessary to enter the name of the series and to

select the reference profile for it. Flange parameters of the selected profile will be
calculated and added to the table of tolerances automatically after saving the series (see
par. 22.3.6).
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22.3.4.     Registration of car/locomotive numbers

Steps to follow: menu Registration > Number. Registered numbers of
cars/locomotives are displayed in the emerged window.  

Functions of buttons are similar to those in par. 22.3.1.

22.3.5.     Registration of tolerances

Steps to follow: menu Registration >Tolerance. Registered series of
cars/locomotives with boundary values of calculated geometric parameters of the wheelset
are displayed in the emerged window. 

Only parameters, which were selected in the list of parameters, are available for
editing (see par. 22.1.2.). 

Maximum/minimum critical values of parameters are indicated with a red color. An
orange color indicates maximum/minimum values of parameters, which are close to critical.

The Norm value is calculated and added to the table automatically when
adding/editing the series of the selected reference (see par. 22.3.3).

22.3.6.     Registration of reference profiles

The program comes with several preset profiles. In addition, the supplied disc with
software contains the base of reference profiles. Profiles are in the Reference Profiles
directory and divided into separate folders for each country.

In addition, the user can form a description of the required profile himself or request
it from RIFTEK (free service). 

To browse available profiles, select menu Registration > Reference:
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The window of profiles displays the table with the list of reference profiles, saved to
database, and a graphical view of the selected profile.  

Buttons functions:

Delete the reference profile 

Import the reference profile from *.re f file

Export the reference profile to *.re f file

Exit the organization registration mode 

22.3.6.1.     Request and registration of the profile file

To get .ref-file of reference profile send the drawing of profile to RIFTEK
(info@riftek.com). Register the received .ref-file as follows:

· click Import
· in the window appeared indicate the way to the .ref-file
· click Open
The profile will be added to the base of reference profiles.
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23.     Data exchange between PDA and PC
To exchange data between PC and PDA, you need to select the device: File >

Device > RF303M-PDA. 

Data exchange between PC and PDA is performed by means of direct cable
connection of PDA to PC USB-port (special RF505.42 cable is supplied).  

There are two ways of synchronization via USB cable:
· ActiveSync
· Mass Storage 
For more details see par. 21.2. 

23.1.     ActiveSync synchronization

When you select this type of synchronization, additional features of data exchange
with PDA will be available:

· Transfer of database files to PC 
· Transfer of language files 
· Transfer of reference profile files 
· Transfer of processing scheme files 
· Updating of PDA software

23.1.1.     Transfer of database file to PC

To transfer the database file from PDA to PC, it is necessary to:
· select PDA > Import Data

· mark the required files in the emerged window and click OK 
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To transfer the language file from PC to PDA, it is necessary to:
· select PDA > Language file > Export

· select the required file

If transfer is successful, the screen will show:
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23.1.3.     Transfer of language file from PDA to PC

To transfer the language file from PDA to PC, it is necessary to:
· select PDA > Language file > Import

· select the required file 

If transfer is successful, the selected files will be saved in the specified path.

23.1.4.     Transfer of reference profile files from PC to PDA

To transfer the reference profile file from PC to PDA, it is necessary to:
· select PDA > Reference file > Export

· select the required .ref file
If transfer is successful, the screen will show:
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23.1.5.     Transfer of processing scheme file from PC to PDA

To transfer the processing scheme file from PC to PDA, it is necessary to:
· select PDA > Scheme file > Export

· select the required .sch file
If transfer is successful, the screen will show:

23.1.6.     Updating of PDA software

The latest software version can be downloaded from the site:
www.riftek.com/media/documents/ikp/Ikp5_PDA_Software.zip. 
To transfer the update file to PDA, it is necessary to:
· select PDA > PDA update 

· select file for transfer
If transfer is successful, the window will appear:

http://www.riftek.com/media/documents/ikp/Ikp5_PDA_Software.zip
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23.2.     Mass Storage synchronization

When you select this type of synchronization, PDA is detected as an external
storage device. Therefore, the only Import Data item is active. Transfer of
language/scheme/reference files  from PDA to PC and back can be performed by simple
copying.

To transfer database files from PDA to PC, it is necessary to:
· select PDA > Import Data
· specify the path to the database on PDA (by default, SDMMC\Autorun\DB)

· mark the required files in the emerged window and click OK 
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24.     Working with profilograms and wear
calculations

24.1.     Browsing the graph and the profile coordinates

To browse the saved profiles of the rolling surface, select Database > Profiles, or

click the Profiles button - .

At the left side of the window you can see the Table of profiles tab, which contains
a list of saved profiles. The table displays only the identification parameters of the wheel,
which were selected in the parameters window (see par. 22.1.).

When selecting a profile, it is possible to browse a graphical image and geometric
parameters of the measured wheel. To browse the coordinates of the selected profile you
need to click the Profile Values button. After that an additional tab with the measured
coordinates will appear.

Buttons functions:

Show/hide the Wear graph

Show/hide the Profile Values tab

Show/hide the Profile alignment tab 

Save the profile image to file (.bmp file)

Print the profile image 

Change the background color of the graph 

Zoom in/out the profile graph 

Calculate geometric parameters of the wheel 
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24.2.     Parameters tab

Calculated geometric parameters of the profile as well as L-parameters values are
displayed on the Parameters tab, which is at the bottom of the window.

If needed it is possible to change settings of the calculated parameters or support
points (see par. 22.1).

24.2.1.     Selection of comparison profile

To compare a profile with a reference, it is necessary to tick the Compare field.
There are two ways of comparing:

· with the reference
· with the measured profile
When comparing with the reference, select the required reference profile in the

drop-down list.

To compare two arbitrarily chosen profiles to each other (for example, profiles of left
and right wheels), it is necessary to select Measured. The Table of profiles tab will show
an additional table for selection of profile to compare. 

24.2.2.     Selection of L-parameters values

When calculating geometric parameters of wheelsets, the specified support points
will be used (see par. 22.1.3). There are two possible variants of L-parameters:

· General parameters 
· Profile parameters 
When selecting General parameters, values of L-parameters will be taken from the

file of database parameters set by default (see par. 22.1.3).
When selecting Profile parameters, values of L-parameters will be taken from the

saved database profile file, i.e. the values, which were set in PDA when measuring the
wheelset (see par. 14.3.).

Values of L-parameters are displayed on the screen in the table of parameters.

If needed, it is possible to edit any value and to recalculate values of geometric
parameters of the flange. To do it, click Calculate. Parameters of the measured profile and
selected reference will be recalculated. 
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24.2.3.     Geometric parameters of the profile

The table of measured geometric parameters displays only parameters, which were
selected in the parameters window (see par. 22.1.2).

Parameters, which are beyond the set tolerances, are highlighted in red/orange
(see par. 22.3.5).

24.3.     Wear calculation

24.3.1.     Fast wear calculation

To obtain fast calculation of the profile wear at a certain point relative to the
reference, put cursor bar to any of the profiles, and when a cross-like (+) mouse cursor
appears press the left mouse key. The resulting screen will show the value of the coordinate
difference between profiles taken along X- and Y-axes, as shown by arrows:

To remove size indication from the screen, it is necessary to put cursor to any of the
profiles and press the right mouse key.

24.3.2.     Wear calculation at all points

To calculate the wear at all points of the measured profile, it is necessary to click the
Wear button. Calculated wear will be displayed on the screen in a graphic form:
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The graph displays positive and negative values of the wear area. Value of the wear
area is calculated in square millimeters with respect to the selected reference profile:

To view the table of wear values, it is necessary to select Profile Values > Wear.
The table will show deviations of the selected profile from the reference profile in two
directions (X and Y).

To save the table in the Excel-format, it is necessary to click the right mouse key in
the table values section. The pop-up window will appear:

· Edit
· Save to the file
When selecting Edit, the editor window will appear, in which you can edit values

and save them in the .xls format.
To save you need to:
· select File > Save
· select Excel 5 (*.xls)
· type the file name and click Save

When selecting Save to the file, a standard dialog for saving the file will appear.
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24.4.     Alignment of profiles

To superimpose profiles (by vertical translation), you need to click the Alignment
button. An additional tab will appear. Next, select the profile to be translated: Reference or
Measured. The selected profile will be marked with red. 

   
After selecting the profile the screen will display the maximum and minimum

deviations of the selected profile from the reference [Min dY..Max dY].
Next, set the translation step and by using the buttons Up/Down, Left/Right

translate the profile as required. 

To save the changed profile, pass to the tab of identification parameters of the
profile and click Save. 

In order to create a new profile, it is necessary to change identification parameters
of the profile.
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24.5.     Superposition of profiles

To superimpose several changed profiles, you need to mark with a tick the required
profiles in the left-hand table. Selected profiles will be displayed in different colors. 

24.6.     Rescaling

To change the image scale, mark a part of the image with the left mouse key, move

the image by holding it with the right mouse key pressed, or with buttons Increase - 

, Decrease -   and Show all - .

 

25.     Implementation of minimum wheel truing
function

Select Tools > Analysis of profiles. The analysis of wheel profiles allows to
choose such a type of the profile from the reference profiles, for which the total truing depth
of two wheels would be minimal.

In the first table of profiles, select the first required profile of the wheelset (left
wheel); in the second table of profiles, select the second required profile of the wheelset
(right wheel).

The program allows to perform the automatic analysis by all the reference profiles,
which stored in the database, or by the selected profile only.
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· Automatic analysis
Tick the box and click the Analysis button. Profiles in the table of references must

not be marked.

· Analysis by the selected profile
Select the reference profile for analysis and click the Analysis button.

To know the wheel cutting depth in a certain point, put the cursor to any profile, and
when a cross-like (+) mouse cursor appears press the left mouse key. The resulting screen
will show the value of difference between profiles along X- and Y-axes, as shown by arrows.
To remove size indication from the screen, put cursor to any of the profiles and press the
right mouse key.
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26.     Scanning and editing of data

26.1.     Scanning and filtering of data

To scan data, select Database > Table in the menu or click the Table button - .
The form with results will be as follows:

· Hide/show the field 
The table displays the identification and geometric parameters of the wheelset,
which are marked for displaying in the parameters settings (see par. 22.1.1 and 
22.1.2).
· Sorting of data
To sort data for any of the fields, click left mouse key on the header of the field

column:

To cancel data sorting, press the Ctrl key and click left mouse key on the header of
the field column.

· Filtering of data 
In order to filter data in any of the fields, click left mouse key on the header of the

field grouping, and select required value in the emerged drop-down list:

To cancel filtering, all steps should be taken in the reverse order.
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· Data grouping
To group data for any of the fields, click left mouse key on the header of the field

column, and, with the mouse key pressed, drag it onto the table header:

· Changing of the field position order 
To change the field position, click left mouse key on the header of the field column

and, with the mouse key pressed, drag it to the required position:

Buttons functions:

Add the wheel pair 

Delete the selected wheel pair 

Delete all wheel pairs 

Edit the selected wheel pair 

Export the coordinates of wheel pairs to the Excel format

Report preparation 

26.2.     Editing data

You can edit, add and remove data in/from the database.
· Editing data
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To edit the current entry, click the Edit button and input/change required values of
parameters, after the editing is complete click the Save button.

· Adding data

To add a new data entry, click the Add button and type required parameter values, 
after the editing is complete click the Save button.

· Deleting data
To delete the current entry, click the Delete button and confirm the deletion.

· Deleting all selected data
If it is necessary to delete not only one entry but several entries combined by some

condition, filter the data according to the corresponding attribute (see par. 26.1.), click the
D elete all button and confirm the action.

26.3.     Report preparation

When staying in the mode of scanning and editing data, the user can prepare
reports in Excel, RTF, PDF formats, or print out reports. When preparing the report, the
sorting used at the moment, is taken into account.  

To generate a report, press the Report button. The program will offer to select the
following options:
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26.3.1.     Excel-format report

To prepare a report in Excel format, select Report in Excel and click ОК.

26.3.2.     Report for printout

To prepare the report for printout, select Report for printout and click ОК. Data
will be presented in the form of report ready for printout. 
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The top toolbar contains the following buttons for operating with reports: 

· To printout the report, click .

· To save in PDF format, click .

· To save in Excel, RTF or PDF, click  and select the format you need:

27.     Taking measurements under PC control (without
PDA)

The laser scanning module (RF505) can work under direct control of PC without
PDA. To work under direct control of PC, it is necessary to select File > Device > RF505-
Profilometer in the main menu.

After that in the main menu of the program the PDA item will be replaced with the
Profilometer item.

The menu contains two available items:
· Calibration 
· Measurement 
Before start to work with the profilometer, it is necessary to set the COM-port for

Bluetooth-connection between the laser scanning module and PDA. The procedure is
described in the user manual that comes with the Bluetooth-adapter.
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27.1.     Calibration

For the calibration, select Profilometer > C alibration , or click the button . 

27.1.1.     Installation of Bluetooth-connection

To connect, select the COM-port and click the C onnect button.

If the connection is successful, the device will be identified, and calibration
parameters will be obtained. The status will be changed to Connected.

The table of calibration parameters: 
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Buttons:

Measurement

Reading calibration parameters 

Writing calibration parameters 

Automatic setting of calibration parameters

The Auto calibration button will be active, if at least one measurement of the profile is performed
as well as the reference profile is selected.

27.1.2.     Calibration of the profilometer

· Place the profilometer on the calibration block. 
· Select the reference profile from the list (Compare > Reference). 
· Perform the measurement (the Measurement button )
· Perform the calibration (the Auto calibration button)
· Save calibration parameters (the Write param. buton).

Calibration parameters can be set manually. To do it, click left mouse key on the
field of the required parameter value, and enter the new one.

Attention! Writing incorrect values of some parameters can lead to the incorrect work of the
device.

Buttons functions, opportunities of the work with profiles, and the calculation of
required parameters are described in par. 22.
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27.2.     Measurement by using PC

To measure, select Profilometer > Measurement, or click the button . 

After establishing the Bluetooth-connection (see par. 27.1.1), the Measurement
button will be active.

27.2.1.     Saving the data

· Place the profilometer on the wheel 
· Perform the measurement (the Measurement button) 
· Enter the identification parameters of the wheelset 

· To save results, click Save 
· The measured profile will be saved to the database 
Buttons functions, opportunities of the work with profiles, and the calculation of

required parameters are described in par. 22.
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28.     Annex 1. Charging procedure
· Switch off the PDA (laser module). 
· Connect the charging device and PDA (laser module)
· Connect the charging device and 220V
· Time of charging – 4 hours, until blue LED is lit.
· Disconnect the charging device and 220V
· Disconnect the charging device and PDA (laser module)

Attention! Please follow the sequence of these points.

29.     Annex 2. Program for making measurement
schemes

To create the measurement schemes, use the special program 
SchemeBuilder.exe. When the program is started, the main window appears on the
screen:

To form the scheme: 

· Enter the number of cars 

· Enter the number of axles in every car 
· If the measurement of the car is performed in the reverse order, tick the box 

· Select the type of the scheme 

· Click the button to accept 
· Next, enter parameters of all wheelsets sequentially for each car 

· The fields Axle and Car are used to navigate through the scheme 



IKP-5 Series, Model 2016 Year [Revision 3.0.0] 04.01.2016 

Laser Wheel Profilometer. IKP-5 Series, Model 2016 Year

71

· Click the Save scheme button 
· Enter the name of the scheme in the dialog box window

The program allows to edit the existing scheme. To edit the scheme, click the Load
scheme button and select the *.SCH file. After loading, you can edit and save the wheelset
parameters.

To transfer the scheme file to PDA, use the procedure described in par. 23.1.5.
Clarification. The measurement scheme is a text file with extension .sch. User can

create and edit such file by using any text processor. 
Example:

Scheme_EXAMPLE 
{ 

1d-|SM 3|7102|1l|11|SU11|111|1r|11|SU11|111|2l|12|SU12|112|2r|12|SU12|112|3l|13|SU13|113|3r|13|SU13|113|4l|14|SU14|114|4r|14|SU14|114|; 

2d-|SM 3|7202|1l|21|SU21|211|1r|21|SU21|211|2l|22|SU22|212|2r|22|SU22|212|3l|23|SU23|213|3r|23|SU23|213|4l|24|SU24|214|4r|24|SU24|214|; 

3d-|SM 3|7302|1l|31|SU31|311|1r|31|SU31|311|2l|32|SU32|312|2r|32|SU32|312|3l|33|SU33|313|3r|33|SU33|313|4l|34|SU34|314|4r|34|SU34|314|; 

4i-|SM 3|7402|4r|44|SU044|414|4l|44|SU44|414|3r|43|SU43|413|3l|43|SU43|413|2r|42|SU42|412|2l|42|SU42|412|1r|41|SU41|411|1l|41|SU41|411|; 

5i-|SM 3|7502|4r|54|SU54|514|4l|54|SU54|514|3r|53|SU53|513|3l|53|SU53|513|2r|52|SU52|512|2l|52|SU52|512|1r|51|SU51|511|1l|51|SU51|511|; 

6i-|SM 3|7602|4r|64|SU064|614|4l|64|SU64|614|3r|63|SU63|613|3l|63|SU63|613|2r|62|SU62|612|2l|62|SU62|612|1r|61|SU61|611|1l|61|SU61|611|; 

} 

Where:
1d – coaches arranged in direct order (1 – sequence number) 
1i – coached arranged in the reverse order (1 – sequence order)
SM3 – coach series 
7102 -number
1l – sequence number of wheel pair and the side (l- left/r-right) 
11 – axle number 
SU11 – name of wheel set 
111 – running distance of wheel set
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30.     Annex 3. Testing and calibration
We can supply the profilometer complete with an RF432.10 calibration-wheel

simulation unit (Fig. 1A) and R F505C alibr calibration program that are designed for
periodic testing and self-calibration of the profilometer.  

Instead of the calibration unit use can be made of the wheel with known profile
entered to the database (see par. 22.3.6).

Before start the testing and calibration process, it is necessary to set the COM-port
for Bluetooth-connection between the laser scanning module and PDA. The procedure is
described in the user manual that comes with the Bluetooth-adapter.

30.1.     Preparation for testing/calibration

· Install the RF505Calibr program on the PC
· Install Bluetooth-connection between the scanning module and PC 
· Place the profilometer on the calibration unit 
· Run RF505Calibr program

· To install Bluetooth-connection, select the required port 

The device will be identified, and calibration parameters will be read.
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· To perform the measurement, pass to the Profile tab and click Measurement.
After measuring, the display will show the measured profile and the calculated
geometric parameters of the profile: Height (Sh), Thickness (Sd), Slope (qR).
Parameters are measured at support points L1, L2, L3. 

· To compare with the reference, tick the C ompare box and select the required
reference profile in the R eference drop-down list. 

30.2.     Testing

To carry out automatic testing, do the following steps:
· Tick the N Meas. box (number of measurements)
· Specify the number of measurements (5-10)
· Uncheck the Calibr. box, if it is ticked
· Click the Measuring button

· The scanning module will make the specified number of measurements whose
results will be entered to the table (the Data tab). The first three columns will
present measured values of height (Sh), thickness (Sd), and flange slope (qR),
while the other three columns will present deviations of the measured values from
the reference values (d_Sh, d_Sd, d_qR). The Diagram tab is intended for
displaying the diagram of values/deviations of the measured profile from the
selected reference. Deviation of the flange height and thickness from the
reference values must not be more than 0.1 mm. 

· If deviations exceed the permissible value, it is necessary to perform calibration of
the scanning module.
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30.3.     Calibration

To carry out automatic calibration, do the following steps:
· Select the reference profile from the list
· Perform the measurement (the Measuring button)
· Perform the calibration (the Auto calibration button)
· When scanning is completed, perform the testing procedure in accordance with

30.2. In case of positive result, pass to the Parameters tab and save parameters
(the Write parameters button)

· If parameters have incorrect values (negative or zero) for any reason, it is
necessary to restore factory settings by pressing the Load Default button. After
that, recalibrate the profilometer.

Figure  1A

31.     Warranty policy
Warranty assurance for the Laser Profilometer - 24 months from the date of putting

in operation; warranty shelf-life - 12 months.
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32.     Distributors

AUSTRALIA

Applied Measurement
Australia Pty Ltd

RAILWAY INSTRUMENTS ONLY
Thornton Plaza, Unit 5, 

27 Thornton Crescent, Mitcham 
VIC 3132, Australia

Tel: +61 39874 5777
Fax: +61 39874 5888

sales@appliedmeasurement.com.au

w w w .appliedmeasurement.com.au

AUSTRALIA

XN Innovation
LG Centre, Suite 1, Level M, 55 

Parramatta Rd, NSW, 2141, 
Lidcombe, Australia
Tel: +61 28091 2426
Fax: +61 29648 6597
xni.sales@gmail.com

BENELUX

Altheris B.V.
Vlietweg 17a

2266KA Leidschendam
The Netherlands

Tel: +31 70 3924421
Fax: +31 70 3644249

sales@altheris.nl
www.altheris.com

BULGARIA, HUNGARY

RMT Ltd.
R Zahradni 224

739 21 Paskov, Czech Republic
Tel: +420 558640211
Fax: +420 558640218

rmt@rmt.cz
www.rmt.cz

BRAZIL

CAPI Controle e Automaçã o
Ltda

Rua Itororó, 121, CEP 13466-240  
Americana-SP, Brazil
Tel: +55 19 36047068
Fax: +55 19 34681791

capi@capicontrole.com.br 
www.capicontrole.com.br 

CHILE

Verne SpA
Apoquindo 2818, oficina 31, 
Las Condes, Santiago, Chile

Tel: +56 2 228858633
info@verne.cl
www.verne.cl

CHINA

Zhenshangyou Technologies
Co.,Ltd.

Rm 2205-2210, Zhongyou Hotel
1110 Nanshan Road, Nanshan

District 518054 Shenzhen, China
Tel: +86 755-26528100/8011/8012
Fax: +86 755-26528210/26435640

info@51sensors.com
www.51sensors.com

CHINA

Shanghai micron-metrology
com., Ltd.

Room 602 unit 4, lane 399,
Mudan road, Pudong New district

Shanghai, China
Tel: +86-21-68416510

sales@micron-metrology.cn  
www.micron-metrology.cn 

CHINA

JRKtech Co., Ltd.
1F, Building 9, 100 Xianlie Rd.,

Guangzhou, China
Tel: +86 755 85267190/

+86 15989362481

Fax: + 86 755 85267190
shengz_k@163.com 

www.jrktech.com

CZECH REPUBLIC

RMT Ltd.
Zahradni 224

739 21 Paskov, Czech Republic
Tel: +420 558640211
Fax: +420 558640218

rmt@rmt.cz
www.rmt.cz

FINLAND

TERÄSPYÖRÄ-STEELWHEEL OY
RAILWAY INSTRUMENTS ONLY

Juvan teollisuuskatu 28
FI-02920 ESPOO, Finland

Tel: +358 400 422 900
Fax: +358 9 2511 5510

steelwheel@steelwheel.fi 
www.teraspyora.fi

FRANCE

DB Innovation (ALTHERIS
France)

26, avenue de la Mediterranee
34110 Frontignan France

Tel: +33-467786166
Fax: +33-467740134

dbi@altheris.fr 
www.altheris.fr

GERMANY

Disynet GmbH
Breyeller Str. 2

41379, Brueggen
Tel: +49 2157 8799-0

Fax: +49 2157 8799-22
disynet@sensoren.de

www.sensoren.de

GERMANY

BIP-Industrietechnik GmbH
RAILWAY INSTRUMENTS ONLY 

Am Elisabethhof 22,
D-14772 Brandenburg

D-41379 Brueggen, Germany
Tel: +49 (0) 33 81 75 90 0

Fax: +49 (0) 33 81 75 90 11
info@bip-industrie.de 

www.bip-industrietechnik.de

GERMANY

Finger GmbH & Co. KG
OPTICAL MICROMETERS ONLY

Sapelloh 172,
31606 Warmsen, Germany

Tel: +49 5767 96020
Fax: +49 5767 93004
finger@finger-kg.de 

www.finger-kg.de

mailto:sales@appliedmeasurement.com.au
http://www.appliedmeasurement.com.au/
mailto:xni.sales@gmail.com
mailto:sales@altheris.nl
http://www.altheris.com/
mailto:rmt@rmt.cz
http://www.rmt.cz/
mailto:capi@capicontrole.com.br
http://www.capicontrole.com.br/
mailto:info@verne.cl
http://www.verne.cl/
mailto:info@51sensors.com
http://www.51sensors.com/
mailto:sales@micron-metrology.cn
http://www.micron-metrology.cn/
mailto:shengz_k@163.com
http://www.jrktech.com/
mailto:rmt@rmt.cz
http://www.rmt.cz/
mailto:steelwheel@steelwheel.fi
http://www.teraspyora.fi/
mailto:dbi@altheris.fr
http://www.altheris.fr/
mailto:disynet@sensoren.de
http://www.sensoren.de/
mailto:info@bip-industrie.de
http://www.bip-industrietechnik.de/
mailto:finger@finger-kg.de
http://www.finger-kg.de/
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GERMANY

Hylewicz CNC-Technik
SHTRIKH-2 ONLY

Siemensstrasse 13-15,
47608 Geldern, Germany
Tel: +49 2831 91021-20
Fax: +49 2831 91021-99

info@cnc-step.de 
www.cnc-step.de 

INDIA

Pragathi Solutions
#698, 5th Main, 8th Cross,

HAL 3rd Stage,
New Tippasandra Road,
Bangalore, 560075, India

Tel: +91 80 32973388
Tel/fax: +91 80 25293985
Mobile: +91 9448030426/

+919448492380
sales@pragathisolutions.in
arghya@pragathisolutions.in

www.pragathisolutions.in

INDIA

BPI (India)
RAILWAY INSTRUMENTS ONLY
63,Civil Lines, Near Bhagirathi

Colony,
Roorkee, 247667, India
Tel: +91 1332274743 
Tel: +91 9319686784
sales@bpi-india.in

www.bpi-india.in

INDONESIA

PT. DHAYA BASWARA
SANIYASA

Botanic Junction Blok H-9 NO. 7
Mega Kebon Jeruk, Joglo
Jakarta 11640, Indonesia

Tel: + 62 21 29325859

management@ptdbs.co.id

IRAN

Novin Industrial Development
Grp.

Tel: +98 21 44022093-6
Fax: +98 21 43858794

Mobile: +98 9123207518
info@novinid.com
www.novinid.com

ISRAEL

Nisso Dekalo Import Export LTD
1 David Hamelech Street

Herzlia 46661 Israel
Tel: +972-99577888
Fax: +972-99568860

eli@fly-supply.net 
www.fly-supply.net 

www.aircraft-partsupply.com 

ITALY

FAE s.r.l.
Via Tertulliano, 41
20137 Milano, Italy

Tel: +39-02-55187133
Fax: +39-02-55187399

fae@fae.it
www.fae.it

LATVIA, ESTONIA

SIA "SOLARTEX"
RAILWAY INSTRUMENTS ONLY
Duntes 15a, 5th floor, office B7

Riga, Latvia
Tel.: +371 67 130 787

solartex@inbox.lv

MALAYSIA

OptoCom Equiptech (M) Sdn Bhd
H-49-2, Jalan 5, Cosmoplex

Industrial Park, Bandar Baru Salak
Tinggi, Sepang, Malaysia

Tel: 603 8706 6806
Fax: 603 8706 6809
optocom@tm.net.my

www.optocom.com.my

PERU

Verne Perú S.A.C.
Las Codornices 104, 
Surquillo, Lima, Peru

Tel/fax: +51 992436734
info@verne.cl
www.verne.cl

POLAND

MTL ASCO Sp. z o.o.
RAILWAY INSTRUMENTS ONLY

ul. Wielowiejska 53
44-120 PYSKOWICE (k/ GLIWIC),

Poland
Tel: + 48 32 230 45 70
Fax: + 48 32 332 70 14

rail@ascorail.eu
www.ascorail.eu

PORTUGAL

UltraSens
Qt. da Portela, Lt. 22.1, Ap. 152
3030 - 502 Coimbra, Portugal

Phone +351 239 796 277
Fax: +351 239 918 267

info@ultrasens.com
www.ultrasens.com

RUSSIA

Sensorika-M LLC
Dmitrovskoye shosse 64-4
127474, Moscow, Russia

Tel: +7 499 487 0363
Fax: +7 499 487 7460
info@sensorika.com
www.sensorika.com

RUSSIA

Diesel-test-Komplekt LLC
620030, Karjernaya St, 16 

Ekaterinburg, Russia
Tel/fax: +7 343 2227565
Tel/fax: +7 343 2227370

mail@d-test.ru
www.d-test.ru

SERBIA, SLOVAKIA

RMT Ltd.
Zahradni 224

739 21 Paskov, Czech Republic
Tel: +420 558640211
Fax: +420 558640218

rmt@rmt.cz
www.rmt.cz

mailto:info@cnc-step.de
http://www.cnc-step.de/
mailto:sales@pragathisolutions.in
mailto:arghya@pragathisolutions.in
http://www.pragathisolutions.in/
mailto:sales@bpi-india.in
http://www.bpi-india.in
mailto:management@ptdbs.co.id
mailto:info@novinid.com
http://www.novinid.com
mailto:eli@fly-supply.net
http://www.fly-supply.net
http://www.aircraft-partsupply.com/
mailto:fae@fae.it
http://www.fae.it/
mailto:solartex@inbox.lv
mailto:optocom@tm.net.my
http://www.optocom.com.my/
mailto:info@verne.cl
http://www.verne.cl/
mailto:rail@ascorail.eu
http://www.ascorail.eu/
mailto:info@ultrasens.com
http://www.ultrasens.com/
mailto:info@sensorika.com
http://www.sensorika.com/
mailto:mail@d-test.ru
http://www.d-test.ru/
mailto:rmt@rmt.cz
http://www.rmt.cz/
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SOUTH AFRICA

Ratcom Enterprise Pty Ltd
CSIR BUILDING 35, Office 78 Meiring

Naude Road, Brummeria 
Pretoria, 0084 South Africa

Tel: + 27 12 841 2032

Fax: + 27 86 225 0650

info@ratcom.co.za
 www.ratcom.co.za 

SOUTH KOREA

PROSEN. CO., LTD
M-1001, Songdo techno park IT
center, 32, Songdogwahak-ro,

Yeonsu-gu,
Incheon, 21984, Republic of Korea

Tel: +82-32-811-3457
Fax: +82-32-232-7458

trade@prosen.co.kr
www.prosen.co.kr

SPAIN

Iberfluid Instruments S.A.
C/ Botanica, 122

08908 L'Hospitalet de Llobregat,
Barcelona

Tel: +34 93 447 10 65
Fax: +34 93 334 05 24
myct@iberfluid.com
www.iberfluid.com

SWITZERLAND

ID&T GmbH
Gewerbestrasse 12/a

8132 Egg (Zurich), Switzerland

Tel: + 41 44 994 92 32

Fax: + 41 44 994 92 34

info@idtlaser.com
www.idtlaser.com 

SWEDEN, NORWAY,
DENMARK

BLConsult
Ryssbält 294,

95 291 KALIX, Sweden
Mobile: +46 70 663 19 25

info@blconsult.se
www.blconsult.se

THAILAND

Advantech Solution Co.,Ltd.
20/170 Motorway Rd.,

Kwang Pravet, Khet Pravet,
Bangkok, Thailand 10250

Tel: +662-1848705
Fax: +662-1848708

sales@advantechsolution.com
www.advantechsolution.com

UKRAINE

KODA
Frunze st 22

61002, Harkov, Ukraine
Tel/fax: +38 057 714 26 54

mail@koda.com.ua
www.koda.com.ua

UNITED KINGDOM,
IRELAND

Ix thus Instrumentation Ltd
The Stables, Williams' Barns

Tiffield road, Towcester, Northents
Tel: +44 1327 353437
Fax: +44 1327 353564

info@ixthus.co.uk
www.ixthus.co.uk

USA, CANADA, MEXICO

International Electronic
Machines Corporation

RAILWAY INSTRUMENTS ONLY
850 River Street, Troy,

New York, USA
Tel: +1 518 268-1636
Fax: +1 518 268-1639

railway_marketing@iem.net
www.iem.net

USA, CANADA, MEXICO

Acuity Products of Schmitt
Industries, Inc. 

2765 NW Nicolai Street
Portland, OR, 97210, USA 

Tel: +1 503 227 7908
Fax: +1 503 223 1258

sales@acuitylaser.com 
www.acuitylaser.com

mailto:info@ratcom.co.za
http://www.ratcom.co.za/
mailto:trade@prosen.co.kr
http://www.prosen.co.kr/
mailto:myct@iberfluid.com
http://www.iberfluid.com/
mailto:info@idtlaser.com
http://www.idtlaser.com/
mailto:info@blconsult.se
http://www.blconsult.se/
mailto:sales@advantechsolution.com
http://www.advantechsolution.com/
mailto:mail@koda.com.ua
http://www.koda.com.ua/
mailto:info@ixthus.co.uk
http://www.ixthus.co.uk/
mailto:railway_marketing@iem.net
http://www.iem.net/
mailto:sales@acuitylaser.com
http://www.acuitylaser.com/
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33.     RIFTEK’s measurement devices for railway
transport

Laser wheel profilometer. IKP Series

A laser profilometer  is designed for the measuring of:
· wheel flange height;

· wheel flange thickness;

· wheel flange slope;

· full profile scanning and analyze of wheel rolling
surface;

· maintaining of electronic wear data base;

· control of tolerances and sorting in the course of
checkup, examination, repair and formation of
railway wheel sets.

Measurements are made directly on rolling stock without
wheel set roll-out.

Portable laser rail profilometer. PRP Series

The main functions of PRP are:
· obtaining the information on the cross-section

profile of the working railhead surface; 
· full profile scanning and analyze of the railhead

acting face;
· visualization of the combined graphical images of

actual and new cross-section railhead profiles on
the display of system unit.

Wheel diameter measuring gauge. IDK Series

Electronic gauge is designed for measuring wheel rolling
circle diameter of railway, metro and tram wheel sets. 

Measurements are made directly on rolling stock without
wheel set roll-out. 
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Back-to-back distance measuring gauge. IMR Series

Gauge is designed for contactless measuring of back-to-
back distance of railway, metro and tram wheels in the
course of checkup, examination, repair and formation of
wheel sets. 
Measurements are made directly on rolling stock without
wheel set roll-out.

Back-to-back distance measuring gauge. IMR-L Series

Gauge is designed for contactless measuring of back-to-
back distance of railway, metro and tram wheels in the
course of checkup, examination, repair and formation of
wheel sets. 
Measurements are made directly on rolling stock without
wheel set roll-out.

Disc brakes profile gauge, IKD Series

Laser disc brakes profilometer IKD Series is designed for
disc brakes profile measuring.
The main functions of IKD are: 

· obtaining the information on the profile parameters of
the working disc brakes surface; 

· full profile scanning and analyze of the disc brakes
acting face;

· visualization of the combined graphical images of
actual and new disc brakes profiles on the display of
system unit. 

Automatic real-time system for measurement of
wheelsets geometrical parameters

The system is designed for contactless automatic
measurement of geometrical parameters of railway wheels
and uses a combination of 2D laser scanners, mounted
wayside in the track area.

The system can be easily installed at any type of rail
infrastructure.
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